<!DOCTYPE html><html lang="en-US" class="no-js no-svg"><head><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[f.now()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,t){s[t]=o(d+t,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),t.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(l+"tracer",[f.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[f.now(),r,o],n),o)try{return t.apply(this,arguments)}catch(e){throw c.emit("fn-err",[arguments,this,e],n),e}finally{c.emit("fn-end",[f.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){m[t]=o(l+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,f.now()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],4:[function(e,t,n){t.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o,i){if(!d.aborted||i){e&&e(n,r,o);for(var a=t(o),u=m(n),c=u.length,f=0;f<c;f++)u[f].apply(a,r);var p=s[y[n]];return p&&p.push([b,n,r,a]),a}}function l(e,t){v[e]=m(e).concat(t)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(n)}function g(e,t){f(e,function(e,n){t=t||"feature",y[n]=t,t in s||(s[t]=[])})}var v={},y={},b={on:l,emit:n,get:w,listeners:m,context:t,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},p={},d=t.exports=o();d.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!x++){var e=h.info=NREUM.info,t=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return s.abort();f(y,function(t,n){e[t]||(e[t]=n)}),c("mark",["onload",a()+h.offset],null,"api");var n=d.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===d.readyState&&i()}function i(){c("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),c=e("handle"),f=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1071.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=t.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),c("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="shortcut icon" href="http://seminolesweb-8b76.kxcdn.com/favicon.ico"><link type="text/css" media="all" href="http://seminolesweb-8b76.kxcdn.com/wp-content/cache/autoptimize/css/autoptimize_1d1df081cf0276f1927dddec0ae7719f.css" rel="stylesheet" /><title>Practice Report: Warrick, Haggins Make For Special Day 6</title><meta name="description" content="TALLAHASSEE, Fla. – Peter Warrick figured he was in Tallahassee to meet Florida State’s new coaching staff and tour his old stomping grounds with his son, Peter Jr. Odell Haggins figured it was a typical Friday during spring camp, a two-and-a-half-hour session in shells before the team’s first scrimmage the next day. But after the Seminoles sped through 25 periods in the Albert J. Dunlap Practice Facility on a rainy morning, Warrick and Haggins, two of FSU’s all-time greats at their respective positions, were each honored and surprised with moments they’ll never forget. It started when Rob Wilson, FSU’s associate athletics director for communications and longtime media relations director for Bobby Bowden in the 1990s, introduced Warrick to the current team in the post-practice huddle. After Wilson reeled off Warrick’s laundry list of accomplishments – being a two-time consensus All-American, FSU’s all-time leader in receiving touchdowns, a 1999 national champion and 2001 first-round draft pick among them – he revealed to Warrick the real reason he was standing in front of the team: Warrick’s No. 9 jersey will be retired this fall. Congrats to @Pdub80! 👏 He will have his #9 jersey retired this fall, just the 11th in FSU history.#SpringBall | #DoSomething pic.twitter.com/iI2fk59VdV — FSU Football (@FSUFootball) March 30, 2018 “This is like the best news ever,” Warrick said with a wide grin. “I honestly didn’t have a clue. ... It was a shock, but it’s a blessing. I’m overwhelmed. They almost made me shed a tear.” Moments later, Doug Mannheimer, chairman of the FSU Hall of Fame and Recognition Committee, stepped in front of the team to deliver one more honor, this one to someone with whom the current Seminoles are a little more familiar. Haggins, the former Seminole defensive lineman who has spent 25 years as an assistant, and who steadied the program as interim head coach last December, will be inducted into the FSU Athletics Hall of Fame later this year. A heartfelt speech from @odellhaggins. This is what he told the team after learning about his induction into the @Seminoles Hall of Fame.#SpringBall | #DoSomething pic.twitter.com/SmKx7zp78C — FSU Football (@FSUFootball) March 30, 2018 “I’m lost for words, but it means a lot,” Haggins said. “I was given this opportunity by Bobby Bowden to be here as a player. And it made me a better man, in my life, the way he treated me. … This place has done a lot for me, and I thank Florida State and the people at Florida State University for giving me this opportunity back in 1985. It means the world. … I just want to thank God for that.” Warrick is joining company both exclusive and elite. He’s the 11th FSU football player to have his jersey retired, and first since linebacker Marvin Jones (55) in 2015. The others include Deion Sanders (2), Derrick Brooks (10), Chris Weinke (16), Charlie Ward (17), Fred Biletnikoff (25), Terrell Buckley (27), Warrick Dunn (28), Ron Sellers (34) and Ron Simmons (50). Haggins, meanwhile, will be the 99th FSU football player to join the Hall of Fame. Per committee policy, current university employees are not eligible to be inducted. But given both the length and significance of Haggins’ contributions to Florida State, the committee made an exception. “It couldn’t go to two better guys than Odell and Peter Warrick,” coach Willie Taggart said. “Both guys love this place, both guys take care of their business and both those guys help make us proud.” One of Taggart’s priorities over the last few weeks has been to get more former players involved with the program and, in turn, to have his players learn as much as they can from their predecessors. Warrick certainly seemed up for it. After practice, he spoke to a huddled group of receivers for several minutes, then stuck around to toss passes, pose for pictures and exchange phone numbers. S/o To big bro @Pdub80 on getting his Number Retired Big Blessings Hard work pay off  He came and Handed Me the torch Today ✈️🙏🏾 #SkrtSkrt pic.twitter.com/AFbpzBEXS1 — 🖤 (@dat_dj) March 30, 2018 “I’m always talking about, ‘Do Something,’ and Peter did something,” said Taggart, who grew up near Warrick in Palmetto, Fla., and competed against him in both youth and high-school football. “That just goes to show how much everyone appreciates what he did here. He’s always been that way. It was expected. Peter has always been the man. He’s been a dude his entire life.” And Haggins, of course, has been pouring himself into future generations ever since joining Bowden’s staff in 1994. As far as Taggart is concerned, there is no better bridge between the players of yesterday and today. “Odell doesn’t just talk about it. He is about it,” Taggart said. “He lives the Florida State way. You can tell that that garnet and gold is in his DNA, and the guys appreciate that.” Here are other highlights from Friday’s practice. Terry, Gavin embrace expanded roles: While the Seminoles might not have the deepest numbers on their receiver depth chart, they more than make up for it in apparent big-play ability. Although much of the focus this spring has been on sophomore D.J. Matthews and the injured Nyqwan Murray, both redshirt freshman Tamorrion Terry and junior Keith Gavin have spent the last week providing FSU’s quarterbacks with big-bodied targets on the outside. The two are working almost exclusively with the first-team offense, they have made at least one big play in seemingly every practice, and, most importantly to James Blackman, Bailey Hockman and Deondre Francois, they are both able to get up high and make plays on the ball. Terry stands at 6-foot-4, 197 pounds, while Gavin isn’t far behind at 6-3, 217. “(Lining up outside) was new to me,” Gavin said. “I like it a lot, though. I still have 1-on-1 (matchups) with most DBs and I have a lot of room to work.” Gavin is looking to take a step forward from last year, in which he appeared in 10 games and finished with 27 catches for 278 yards. And Terry is in line to make his first impact at the college level after redshirting a year ago. “Those guys are strong, they’re physical,” Taggart said. “Whenever you’ve got strong, physical receivers that can catch the ball, they can do a lot of damage for you.” Situational scrimmage up next: Taggart will cross off another checkpoint on Saturday morning when he holds his first team scrimmage as Florida State’s head coach. Rather than have a true game simulation, Taggart intends to work offense versus defense in a number of in-game scenarios – think red-zone, short-yardage, two-minute drill and the like. A full scrimmage will follow at the end of next week’s practices, and, of course, the Garnet &amp; Gold Game will be held on April 14. “So often, you just put them out there, 11-on-11, and tell them to play football. And they’re running plays but they’re not understanding the situation,” Taggart said. “We’re just trying to teach our guys the game. We’re going to put our guys in a lot of game situations and make sure they’re locked in and understanding where they’re at and not just running lines in a playbook.” Specialists pushing themselves: For the first time in their careers, specialists Ricky Aguayo and Logan Tyler have a dedicated position coach in Alonzo Hampton. And they’re also among the only Seminoles without any competition for their starting jobs. At least not in the most obvious sense. But while the two veterans will likely reprise their roles as FSU’s kicker and punter this fall, that doesn’t mean Taggart has them resting on their laurels this spring. Tyler has looked solid throughout the spring, booming a number of kicks to a waiting group of returners that includes Levonta Taylor, Khalan Laborn, D.J. Matthews, Gavin and Zaquandre White. And Taggart has kept Aguayo engaged by implementing the kicking version of a pop quiz – surprise field-goal drills during practice in which Aguayo must step up and attempt without any advanced notice. If Aguayo makes it, the team might be in for a lighter day of post-practice conditioning. If he misses, well ... let’s just say it makes for about as much pressure as there can be in mid-March. “There will be times in practice where we’ll just call a field goal,” Taggart said. “And you’ve got to be ready. You don’t know when that time’s going to be … You’ve just got to be ready to come win the ballgame for us.” Atkins brothers visit: It’s getting a little tricky to keep up with all the former players visiting, but, in addition to Warrick, former FSU lineman Dumaka Atkins and his brother, former Miami standout Baraka Atkins, were in attendance. The two competed against each other during the mid-2000s. Extra highlights: Bailey Hockman had an impressive sequence in which he evaded a heavy pass rush, rolled to his left and floated a pass over a defender and into the arms of Deonte Sheffield, who took care of the rest for a long touchdown. … Sheffield later a caught another TD on a smooth crossing route across the back of the end zone during 7 on 7 drills. … White broke free for a 45-yard touchdown run up the middle. … Levonta Taylor showed off his instincts and athleticism by sitting on a short out route, jumping in front of the pass and taking off for what would have been an easy pick-six during short-yardage drills. (Incidentally, the quarterback who threw the pass then took off for a lap around the practice field, another new Taggart tradition.) Follow @Tim_Linafelt" /><meta name="keywords" content="florida state seminoles, florida state, fsu, seminoles, seminoles football, seminoles basketball, seminoles baseball, seminoles soccer, garnet, bcs national champions, doak campbell stadium, fsu football, fsu basketball, fsu baseball, headlines, noles insiders, featured story, more headlines, football, noles insiders" /><meta property="og:site_name" content="Florida State Seminoles" /><meta property="og:type" content="article" /><meta property="og:title" content="Practice Report: Warrick, Haggins Make For Special Day 6" /><meta property="og:url" content="http://seminoles.com/practice-report-warrick-haggins-make-for-special-day-6/" /><meta property="og:description" content="TALLAHASSEE, Fla. – Peter Warrick figured he was in Tallahassee to meet Florida State’s new coaching staff and tour his old stomping grounds with his son, Peter Jr. Odell Haggins figured it was a typical Friday during spring camp, a two-and-a-half-hour session in shells before the team’s first scrimmage the next day. But after the Seminoles sped through 25 periods in the Albert J. Dunlap Practice Facility on a rainy morning, Warrick and Haggins, two of FSU’s all-time greats at their respective positions, were each honored and surprised with moments they’ll never forget. It started when Rob Wilson, FSU’s associate athletics director for communications and longtime media relations director for Bobby Bowden in the 1990s, introduced Warrick to the current team in the post-practice huddle. After Wilson reeled off Warrick’s laundry list of accomplishments – being a two-time consensus All-American, FSU’s all-time leader in receiving touchdowns, a 1999 national champion and 2001 first-round draft pick among them – he revealed to Warrick the real reason he was standing in front of the team: Warrick’s No. 9 jersey will be retired this fall. Congrats to @Pdub80! 👏 He will have his #9 jersey retired this fall, just the 11th in FSU history.#SpringBall | #DoSomething pic.twitter.com/iI2fk59VdV — FSU Football (@FSUFootball) March 30, 2018 “This is like the best news ever,” Warrick said with a wide grin. “I honestly didn’t have a clue. ... It was a shock, but it’s a blessing. I’m overwhelmed. They almost made me shed a tear.” Moments later, Doug Mannheimer, chairman of the FSU Hall of Fame and Recognition Committee, stepped in front of the team to deliver one more honor, this one to someone with whom the current Seminoles are a little more familiar. Haggins, the former Seminole defensive lineman who has spent 25 years as an assistant, and who steadied the program as interim head coach last December, will be inducted into the FSU Athletics Hall of Fame later this year. A heartfelt speech from @odellhaggins. This is what he told the team after learning about his induction into the @Seminoles Hall of Fame.#SpringBall | #DoSomething pic.twitter.com/SmKx7zp78C — FSU Football (@FSUFootball) March 30, 2018 “I’m lost for words, but it means a lot,” Haggins said. “I was given this opportunity by Bobby Bowden to be here as a player. And it made me a better man, in my life, the way he treated me. … This place has done a lot for me, and I thank Florida State and the people at Florida State University for giving me this opportunity back in 1985. It means the world. … I just want to thank God for that.” Warrick is joining company both exclusive and elite. He’s the 11th FSU football player to have his jersey retired, and first since linebacker Marvin Jones (55) in 2015. The others include Deion Sanders (2), Derrick Brooks (10), Chris Weinke (16), Charlie Ward (17), Fred Biletnikoff (25), Terrell Buckley (27), Warrick Dunn (28), Ron Sellers (34) and Ron Simmons (50). Haggins, meanwhile, will be the 99th FSU football player to join the Hall of Fame. Per committee policy, current university employees are not eligible to be inducted. But given both the length and significance of Haggins’ contributions to Florida State, the committee made an exception. “It couldn’t go to two better guys than Odell and Peter Warrick,” coach Willie Taggart said. “Both guys love this place, both guys take care of their business and both those guys help make us proud.” One of Taggart’s priorities over the last few weeks has been to get more former players involved with the program and, in turn, to have his players learn as much as they can from their predecessors. Warrick certainly seemed up for it. After practice, he spoke to a huddled group of receivers for several minutes, then stuck around to toss passes, pose for pictures and exchange phone numbers. S/o To big bro @Pdub80 on getting his Number Retired Big Blessings Hard work pay off  He came and Handed Me the torch Today ✈️🙏🏾 #SkrtSkrt pic.twitter.com/AFbpzBEXS1 — 🖤 (@dat_dj) March 30, 2018 “I’m always talking about, ‘Do Something,’ and Peter did something,” said Taggart, who grew up near Warrick in Palmetto, Fla., and competed against him in both youth and high-school football. “That just goes to show how much everyone appreciates what he did here. He’s always been that way. It was expected. Peter has always been the man. He’s been a dude his entire life.” And Haggins, of course, has been pouring himself into future generations ever since joining Bowden’s staff in 1994. As far as Taggart is concerned, there is no better bridge between the players of yesterday and today. “Odell doesn’t just talk about it. He is about it,” Taggart said. “He lives the Florida State way. You can tell that that garnet and gold is in his DNA, and the guys appreciate that.” Here are other highlights from Friday’s practice. Terry, Gavin embrace expanded roles: While the Seminoles might not have the deepest numbers on their receiver depth chart, they more than make up for it in apparent big-play ability. Although much of the focus this spring has been on sophomore D.J. Matthews and the injured Nyqwan Murray, both redshirt freshman Tamorrion Terry and junior Keith Gavin have spent the last week providing FSU’s quarterbacks with big-bodied targets on the outside. The two are working almost exclusively with the first-team offense, they have made at least one big play in seemingly every practice, and, most importantly to James Blackman, Bailey Hockman and Deondre Francois, they are both able to get up high and make plays on the ball. Terry stands at 6-foot-4, 197 pounds, while Gavin isn’t far behind at 6-3, 217. “(Lining up outside) was new to me,” Gavin said. “I like it a lot, though. I still have 1-on-1 (matchups) with most DBs and I have a lot of room to work.” Gavin is looking to take a step forward from last year, in which he appeared in 10 games and finished with 27 catches for 278 yards. And Terry is in line to make his first impact at the college level after redshirting a year ago. “Those guys are strong, they’re physical,” Taggart said. “Whenever you’ve got strong, physical receivers that can catch the ball, they can do a lot of damage for you.” Situational scrimmage up next: Taggart will cross off another checkpoint on Saturday morning when he holds his first team scrimmage as Florida State’s head coach. Rather than have a true game simulation, Taggart intends to work offense versus defense in a number of in-game scenarios – think red-zone, short-yardage, two-minute drill and the like. A full scrimmage will follow at the end of next week’s practices, and, of course, the Garnet &amp; Gold Game will be held on April 14. “So often, you just put them out there, 11-on-11, and tell them to play football. And they’re running plays but they’re not understanding the situation,” Taggart said. “We’re just trying to teach our guys the game. We’re going to put our guys in a lot of game situations and make sure they’re locked in and understanding where they’re at and not just running lines in a playbook.” Specialists pushing themselves: For the first time in their careers, specialists Ricky Aguayo and Logan Tyler have a dedicated position coach in Alonzo Hampton. And they’re also among the only Seminoles without any competition for their starting jobs. At least not in the most obvious sense. But while the two veterans will likely reprise their roles as FSU’s kicker and punter this fall, that doesn’t mean Taggart has them resting on their laurels this spring. Tyler has looked solid throughout the spring, booming a number of kicks to a waiting group of returners that includes Levonta Taylor, Khalan Laborn, D.J. Matthews, Gavin and Zaquandre White. And Taggart has kept Aguayo engaged by implementing the kicking version of a pop quiz – surprise field-goal drills during practice in which Aguayo must step up and attempt without any advanced notice. If Aguayo makes it, the team might be in for a lighter day of post-practice conditioning. If he misses, well ... let’s just say it makes for about as much pressure as there can be in mid-March. “There will be times in practice where we’ll just call a field goal,” Taggart said. “And you’ve got to be ready. You don’t know when that time’s going to be … You’ve just got to be ready to come win the ballgame for us.” Atkins brothers visit: It’s getting a little tricky to keep up with all the former players visiting, but, in addition to Warrick, former FSU lineman Dumaka Atkins and his brother, former Miami standout Baraka Atkins, were in attendance. The two competed against each other during the mid-2000s. Extra highlights: Bailey Hockman had an impressive sequence in which he evaded a heavy pass rush, rolled to his left and floated a pass over a defender and into the arms of Deonte Sheffield, who took care of the rest for a long touchdown. … Sheffield later a caught another TD on a smooth crossing route across the back of the end zone during 7 on 7 drills. … White broke free for a 45-yard touchdown run up the middle. … Levonta Taylor showed off his instincts and athleticism by sitting on a short out route, jumping in front of the pass and taking off for what would have been an easy pick-six during short-yardage drills. (Incidentally, the quarterback who threw the pass then took off for a lap around the practice field, another new Taggart tradition.) Follow @Tim_Linafelt" /><meta property="og:locale" content="en_US" /><meta property="og:updated_time" content="2018-03-30T17:22:00+00:00" /><meta name="og:image" content="http://seminoles.com/amt-media/321915" /><meta property="article:published_time" content="2018-03-30T17:09:34+00:00" /><meta property="article:modified_time" content="2018-03-30T17:22:00+00:00" /><meta property="article:publisher" content="https://www.facebook.com/FSUSeminoles/" /><meta property="article:section" content="Headlines" /><meta property="article:section" content="Noles Insiders" /><meta property="article:section" content="Featured Story" /><meta property="article:section" content="More Headlines" /><meta property="article:tag" content="florida state seminoles" /><meta property="article:tag" content="florida state" /><meta property="article:tag" content="fsu" /><meta property="article:tag" content="seminoles" /><meta property="article:tag" content="seminoles football" /><meta property="article:tag" content="seminoles basketball" /><meta property="article:tag" content="seminoles baseball" /><meta property="article:tag" content="seminoles soccer" /><meta property="article:tag" content="garnet" /><meta property="article:tag" content="bcs national champions" /><meta property="article:tag" content="doak campbell stadium" /><meta property="article:tag" content="fsu football" /><meta property="article:tag" content="fsu basketball" /><meta property="article:tag" content="fsu baseball" /><meta property="article:tag" content="football" /><meta property="article:tag" content="noles insiders" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@@Tim_Linafelt" /><meta name="twitter:site" content="@Seminoles" /><meta name="twitter:title" content="Practice Report: Warrick, Haggins Make For Special Day 6" /><meta name="twitter:description" content="TALLAHASSEE, Fla. – Peter Warrick figured he was in Tallahassee to meet Florida State’s new coaching staff and tour his old stomping grounds with his son, Peter Jr. Odell Haggins figured it was a typical Friday during spring camp, a two-and-a-half-hour session in shells before the team’s first scrimmage the next day. But after the Seminoles sped through 25 periods in the Albert J. Dunlap Practice Facility on a rainy morning, Warrick and Haggins, two of FSU’s all-time greats at their respective positions, were each honored and surprised with moments they’ll never forget. It started when Rob Wilson, FSU’s associate athletics director for communications and longtime media relations director for Bobby Bowden in the 1990s, introduced Warrick to the current team in the post-practice huddle. After Wilson reeled off Warrick’s laundry list of accomplishments – being a two-time consensus All-American, FSU’s all-time leader in receiving touchdowns, a 1999 national champion and 2001 first-round draft pick among them – he revealed to Warrick the real reason he was standing in front of the team: Warrick’s No. 9 jersey will be retired this fall. Congrats to @Pdub80! 👏 He will have his #9 jersey retired this fall, just the 11th in FSU history.#SpringBall | #DoSomething pic.twitter.com/iI2fk59VdV — FSU Football (@FSUFootball) March 30, 2018 “This is like the best news ever,” Warrick said with a wide grin. “I honestly didn’t have a clue. ... It was a shock, but it’s a blessing. I’m overwhelmed. They almost made me shed a tear.” Moments later, Doug Mannheimer, chairman of the FSU Hall of Fame and Recognition Committee, stepped in front of the team to deliver one more honor, this one to someone with whom the current Seminoles are a little more familiar. Haggins, the former Seminole defensive lineman who has spent 25 years as an assistant, and who steadied the program as interim head coach last December, will be inducted into the FSU Athletics Hall of Fame later this year. A heartfelt speech from @odellhaggins. This is what he told the team after learning about his induction into the @Seminoles Hall of Fame.#SpringBall | #DoSomething pic.twitter.com/SmKx7zp78C — FSU Football (@FSUFootball) March 30, 2018 “I’m lost for words, but it means a lot,” Haggins said. “I was given this opportunity by Bobby Bowden to be here as a player. And it made me a better man, in my life, the way he treated me. … This place has done a lot for me, and I thank Florida State and the people at Florida State University for giving me this opportunity back in 1985. It means the world. … I just want to thank God for that.” Warrick is joining company both exclusive and elite. He’s the 11th FSU football player to have his jersey retired, and first since linebacker Marvin Jones (55) in 2015. The others include Deion Sanders (2), Derrick Brooks (10), Chris Weinke (16), Charlie Ward (17), Fred Biletnikoff (25), Terrell Buckley (27), Warrick Dunn (28), Ron Sellers (34) and Ron Simmons (50). Haggins, meanwhile, will be the 99th FSU football player to join the Hall of Fame. Per committee policy, current university employees are not eligible to be inducted. But given both the length and significance of Haggins’ contributions to Florida State, the committee made an exception. “It couldn’t go to two better guys than Odell and Peter Warrick,” coach Willie Taggart said. “Both guys love this place, both guys take care of their business and both those guys help make us proud.” One of Taggart’s priorities over the last few weeks has been to get more former players involved with the program and, in turn, to have his players learn as much as they can from their predecessors. Warrick certainly seemed up for it. After practice, he spoke to a huddled group of receivers for several minutes, then stuck around to toss passes, pose for pictures and exchange phone numbers. S/o To big bro @Pdub80 on getting his Number Retired Big Blessings Hard work pay off  He came and Handed Me the torch Today ✈️🙏🏾 #SkrtSkrt pic.twitter.com/AFbpzBEXS1 — 🖤 (@dat_dj) March 30, 2018 “I’m always talking about, ‘Do Something,’ and Peter did something,” said Taggart, who grew up near Warrick in Palmetto, Fla., and competed against him in both youth and high-school football. “That just goes to show how much everyone appreciates what he did here. He’s always been that way. It was expected. Peter has always been the man. He’s been a dude his entire life.” And Haggins, of course, has been pouring himself into future generations ever since joining Bowden’s staff in 1994. As far as Taggart is concerned, there is no better bridge between the players of yesterday and today. “Odell doesn’t just talk about it. He is about it,” Taggart said. “He lives the Florida State way. You can tell that that garnet and gold is in his DNA, and the guys appreciate that.” Here are other highlights from Friday’s practice. Terry, Gavin embrace expanded roles: While the Seminoles might not have the deepest numbers on their receiver depth chart, they more than make up for it in apparent big-play ability. Although much of the focus this spring has been on sophomore D.J. Matthews and the injured Nyqwan Murray, both redshirt freshman Tamorrion Terry and junior Keith Gavin have spent the last week providing FSU’s quarterbacks with big-bodied targets on the outside. The two are working almost exclusively with the first-team offense, they have made at least one big play in seemingly every practice, and, most importantly to James Blackman, Bailey Hockman and Deondre Francois, they are both able to get up high and make plays on the ball. Terry stands at 6-foot-4, 197 pounds, while Gavin isn’t far behind at 6-3, 217. “(Lining up outside) was new to me,” Gavin said. “I like it a lot, though. I still have 1-on-1 (matchups) with most DBs and I have a lot of room to work.” Gavin is looking to take a step forward from last year, in which he appeared in 10 games and finished with 27 catches for 278 yards. And Terry is in line to make his first impact at the college level after redshirting a year ago. “Those guys are strong, they’re physical,” Taggart said. “Whenever you’ve got strong, physical receivers that can catch the ball, they can do a lot of damage for you.” Situational scrimmage up next: Taggart will cross off another checkpoint on Saturday morning when he holds his first team scrimmage as Florida State’s head coach. Rather than have a true game simulation, Taggart intends to work offense versus defense in a number of in-game scenarios – think red-zone, short-yardage, two-minute drill and the like. A full scrimmage will follow at the end of next week’s practices, and, of course, the Garnet &amp; Gold Game will be held on April 14. “So often, you just put them out there, 11-on-11, and tell them to play football. And they’re running plays but they’re not understanding the situation,” Taggart said. “We’re just trying to teach our guys the game. We’re going to put our guys in a lot of game situations and make sure they’re locked in and understanding where they’re at and not just running lines in a playbook.” Specialists pushing themselves: For the first time in their careers, specialists Ricky Aguayo and Logan Tyler have a dedicated position coach in Alonzo Hampton. And they’re also among the only Seminoles without any competition for their starting jobs. At least not in the most obvious sense. But while the two veterans will likely reprise their roles as FSU’s kicker and punter this fall, that doesn’t mean Taggart has them resting on their laurels this spring. Tyler has looked solid throughout the spring, booming a number of kicks to a waiting group of returners that includes Levonta Taylor, Khalan Laborn, D.J. Matthews, Gavin and Zaquandre White. And Taggart has kept Aguayo engaged by implementing the kicking version of a pop quiz – surprise field-goal drills during practice in which Aguayo must step up and attempt without any advanced notice. If Aguayo makes it, the team might be in for a lighter day of post-practice conditioning. If he misses, well ... let’s just say it makes for about as much pressure as there can be in mid-March. “There will be times in practice where we’ll just call a field goal,” Taggart said. “And you’ve got to be ready. You don’t know when that time’s going to be … You’ve just got to be ready to come win the ballgame for us.” Atkins brothers visit: It’s getting a little tricky to keep up with all the former players visiting, but, in addition to Warrick, former FSU lineman Dumaka Atkins and his brother, former Miami standout Baraka Atkins, were in attendance. The two competed against each other during the mid-2000s. Extra highlights: Bailey Hockman had an impressive sequence in which he evaded a heavy pass rush, rolled to his left and floated a pass over a defender and into the arms of Deonte Sheffield, who took care of the rest for a long touchdown. … Sheffield later a caught another TD on a smooth crossing route across the back of the end zone during 7 on 7 drills. … White broke free for a 45-yard touchdown run up the middle. … Levonta Taylor showed off his instincts and athleticism by sitting on a short out route, jumping in front of the pass and taking off for what would have been an easy pick-six during short-yardage drills. (Incidentally, the quarterback who threw the pass then took off for a lap around the practice field, another new Taggart tradition.) Follow @Tim_Linafelt" /><meta name="twitter:image" content="http://seminoles.com/amt-media/321915" /><meta name="dcterms.title" content="Practice Report: Warrick, Haggins Make For Special Day 6" /><meta name="dcterms.identifier" content="http://seminoles.com/practice-report-warrick-haggins-make-for-special-day-6/" /><meta name="dcterms.created" content="2018-03-30T17:09:34+00:00" /><meta name="dcterms.available" content="2018-03-30T17:09:34+00:00" /><meta name="dcterms.modified" content="2018-03-30T17:22:00+00:00" /><meta name="dcterms.description" content="TALLAHASSEE, Fla. – Peter Warrick figured he was in Tallahassee to meet Florida State’s new coaching staff and tour his old stomping grounds with his son, Peter Jr. Odell Haggins figured it was a typical Friday during spring camp, a two-and-a-half-hour session in shells before the team’s first scrimmage the next day. But after the Seminoles sped through 25 periods in the Albert J. Dunlap Practice Facility on a rainy morning, Warrick and Haggins, two of FSU’s all-time greats at their respective positions, were each honored and surprised with moments they’ll never forget. It started when Rob Wilson, FSU’s associate athletics director for communications and longtime media relations director for Bobby Bowden in the 1990s, introduced Warrick to the current team in the post-practice huddle. After Wilson reeled off Warrick’s laundry list of accomplishments – being a two-time consensus All-American, FSU’s all-time leader in receiving touchdowns, a 1999 national champion and 2001 first-round draft pick among them – he revealed to Warrick the real reason he was standing in front of the team: Warrick’s No. 9 jersey will be retired this fall. Congrats to @Pdub80! 👏 He will have his #9 jersey retired this fall, just the 11th in FSU history.#SpringBall | #DoSomething pic.twitter.com/iI2fk59VdV — FSU Football (@FSUFootball) March 30, 2018 “This is like the best news ever,” Warrick said with a wide grin. “I honestly didn’t have a clue. ... It was a shock, but it’s a blessing. I’m overwhelmed. They almost made me shed a tear.” Moments later, Doug Mannheimer, chairman of the FSU Hall of Fame and Recognition Committee, stepped in front of the team to deliver one more honor, this one to someone with whom the current Seminoles are a little more familiar. Haggins, the former Seminole defensive lineman who has spent 25 years as an assistant, and who steadied the program as interim head coach last December, will be inducted into the FSU Athletics Hall of Fame later this year. A heartfelt speech from @odellhaggins. This is what he told the team after learning about his induction into the @Seminoles Hall of Fame.#SpringBall | #DoSomething pic.twitter.com/SmKx7zp78C — FSU Football (@FSUFootball) March 30, 2018 “I’m lost for words, but it means a lot,” Haggins said. “I was given this opportunity by Bobby Bowden to be here as a player. And it made me a better man, in my life, the way he treated me. … This place has done a lot for me, and I thank Florida State and the people at Florida State University for giving me this opportunity back in 1985. It means the world. … I just want to thank God for that.” Warrick is joining company both exclusive and elite. He’s the 11th FSU football player to have his jersey retired, and first since linebacker Marvin Jones (55) in 2015. The others include Deion Sanders (2), Derrick Brooks (10), Chris Weinke (16), Charlie Ward (17), Fred Biletnikoff (25), Terrell Buckley (27), Warrick Dunn (28), Ron Sellers (34) and Ron Simmons (50). Haggins, meanwhile, will be the 99th FSU football player to join the Hall of Fame. Per committee policy, current university employees are not eligible to be inducted. But given both the length and significance of Haggins’ contributions to Florida State, the committee made an exception. “It couldn’t go to two better guys than Odell and Peter Warrick,” coach Willie Taggart said. “Both guys love this place, both guys take care of their business and both those guys help make us proud.” One of Taggart’s priorities over the last few weeks has been to get more former players involved with the program and, in turn, to have his players learn as much as they can from their predecessors. Warrick certainly seemed up for it. After practice, he spoke to a huddled group of receivers for several minutes, then stuck around to toss passes, pose for pictures and exchange phone numbers. S/o To big bro @Pdub80 on getting his Number Retired Big Blessings Hard work pay off  He came and Handed Me the torch Today ✈️🙏🏾 #SkrtSkrt pic.twitter.com/AFbpzBEXS1 — 🖤 (@dat_dj) March 30, 2018 “I’m always talking about, ‘Do Something,’ and Peter did something,” said Taggart, who grew up near Warrick in Palmetto, Fla., and competed against him in both youth and high-school football. “That just goes to show how much everyone appreciates what he did here. He’s always been that way. It was expected. Peter has always been the man. He’s been a dude his entire life.” And Haggins, of course, has been pouring himself into future generations ever since joining Bowden’s staff in 1994. As far as Taggart is concerned, there is no better bridge between the players of yesterday and today. “Odell doesn’t just talk about it. He is about it,” Taggart said. “He lives the Florida State way. You can tell that that garnet and gold is in his DNA, and the guys appreciate that.” Here are other highlights from Friday’s practice. Terry, Gavin embrace expanded roles: While the Seminoles might not have the deepest numbers on their receiver depth chart, they more than make up for it in apparent big-play ability. Although much of the focus this spring has been on sophomore D.J. Matthews and the injured Nyqwan Murray, both redshirt freshman Tamorrion Terry and junior Keith Gavin have spent the last week providing FSU’s quarterbacks with big-bodied targets on the outside. The two are working almost exclusively with the first-team offense, they have made at least one big play in seemingly every practice, and, most importantly to James Blackman, Bailey Hockman and Deondre Francois, they are both able to get up high and make plays on the ball. Terry stands at 6-foot-4, 197 pounds, while Gavin isn’t far behind at 6-3, 217. “(Lining up outside) was new to me,” Gavin said. “I like it a lot, though. I still have 1-on-1 (matchups) with most DBs and I have a lot of room to work.” Gavin is looking to take a step forward from last year, in which he appeared in 10 games and finished with 27 catches for 278 yards. And Terry is in line to make his first impact at the college level after redshirting a year ago. “Those guys are strong, they’re physical,” Taggart said. “Whenever you’ve got strong, physical receivers that can catch the ball, they can do a lot of damage for you.” Situational scrimmage up next: Taggart will cross off another checkpoint on Saturday morning when he holds his first team scrimmage as Florida State’s head coach. Rather than have a true game simulation, Taggart intends to work offense versus defense in a number of in-game scenarios – think red-zone, short-yardage, two-minute drill and the like. A full scrimmage will follow at the end of next week’s practices, and, of course, the Garnet &amp; Gold Game will be held on April 14. “So often, you just put them out there, 11-on-11, and tell them to play football. And they’re running plays but they’re not understanding the situation,” Taggart said. “We’re just trying to teach our guys the game. We’re going to put our guys in a lot of game situations and make sure they’re locked in and understanding where they’re at and not just running lines in a playbook.” Specialists pushing themselves: For the first time in their careers, specialists Ricky Aguayo and Logan Tyler have a dedicated position coach in Alonzo Hampton. And they’re also among the only Seminoles without any competition for their starting jobs. At least not in the most obvious sense. But while the two veterans will likely reprise their roles as FSU’s kicker and punter this fall, that doesn’t mean Taggart has them resting on their laurels this spring. Tyler has looked solid throughout the spring, booming a number of kicks to a waiting group of returners that includes Levonta Taylor, Khalan Laborn, D.J. Matthews, Gavin and Zaquandre White. And Taggart has kept Aguayo engaged by implementing the kicking version of a pop quiz – surprise field-goal drills during practice in which Aguayo must step up and attempt without any advanced notice. If Aguayo makes it, the team might be in for a lighter day of post-practice conditioning. If he misses, well ... let’s just say it makes for about as much pressure as there can be in mid-March. “There will be times in practice where we’ll just call a field goal,” Taggart said. “And you’ve got to be ready. You don’t know when that time’s going to be … You’ve just got to be ready to come win the ballgame for us.” Atkins brothers visit: It’s getting a little tricky to keep up with all the former players visiting, but, in addition to Warrick, former FSU lineman Dumaka Atkins and his brother, former Miami standout Baraka Atkins, were in attendance. The two competed against each other during the mid-2000s. Extra highlights: Bailey Hockman had an impressive sequence in which he evaded a heavy pass rush, rolled to his left and floated a pass over a defender and into the arms of Deonte Sheffield, who took care of the rest for a long touchdown. … Sheffield later a caught another TD on a smooth crossing route across the back of the end zone during 7 on 7 drills. … White broke free for a 45-yard touchdown run up the middle. … Levonta Taylor showed off his instincts and athleticism by sitting on a short out route, jumping in front of the pass and taking off for what would have been an easy pick-six during short-yardage drills. (Incidentally, the quarterback who threw the pass then took off for a lap around the practice field, another new Taggart tradition.) Follow @Tim_Linafelt" /><meta name="dcterms.subject" content="florida state seminoles" /><meta name="dcterms.subject" content="florida state" /><meta name="dcterms.subject" content="fsu" /><meta name="dcterms.subject" content="seminoles" /><meta name="dcterms.subject" content="seminoles football" /><meta name="dcterms.subject" content="seminoles basketball" /><meta name="dcterms.subject" content="seminoles baseball" /><meta name="dcterms.subject" content="seminoles soccer" /><meta name="dcterms.subject" content="garnet" /><meta name="dcterms.subject" content="bcs national champions" /><meta name="dcterms.subject" content="doak campbell stadium" /><meta name="dcterms.subject" content="fsu football" /><meta name="dcterms.subject" content="fsu basketball" /><meta name="dcterms.subject" content="fsu baseball" /><meta name="dcterms.subject" content="headlines" /><meta name="dcterms.subject" content="noles insiders" /><meta name="dcterms.subject" content="featured story" /><meta name="dcterms.subject" content="more headlines" /><meta name="dcterms.subject" content="football" /><meta name="dcterms.subject" content="noles insiders" /><meta name="dcterms.language" content="en-US" /><meta name="dcterms.publisher" content="http://seminoles.com/" /><meta name="dcterms.rights" content="http://seminoles.com/" /><meta name="dcterms.coverage" content="World" /><meta name="dcterms.type" content="Text" /><meta name="dcterms.format" content="text/html" /><link rel="publisher" type="text/html" title="Florida State Seminoles" href="http://seminoles.com/" /><link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//imasdk.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='stylesheet' id='seminoles-style-head-css'  href='http://seminolesweb-8b76.kxcdn.com/wp-content/themes/seminoles/build/css/libraries.css?ver=1521826739' type='text/css' media='all' /><link rel='stylesheet' id='seminoles-style-css'  href='http://seminolesweb-8b76.kxcdn.com/wp-content/themes/seminoles/build/css/seminoles.css?ver=1521299720' type='text/css' media='all' /><link rel='stylesheet' id='seminoles-fonts-css'  href='http://seminolesweb-8b76.kxcdn.com/wp-content/themes/seminoles/build/css/fonts.css?ver=1521299720' type='text/css' media='all' /> <script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4'></script> <script type='text/javascript'>var aamLocal = {"nonce":"79868ed060","ajaxurl":"http:\/\/seminoles.com\/wp-admin\/admin-ajax.php"};</script> <link rel='https://api.w.org/' href='http://seminoles.com/wp-json/' /><link rel='prev' title='Warrick, Haggins Shocked by Honors' href='http://seminoles.com/warrick-haggins-shocked-by-honors/' /><link rel='next' title='Beach Volleyball Splits Day One in South Beach' href='http://seminoles.com/beach-volleyball-splits-day-one-in-south-beach/' /><link rel="canonical" href="http://seminoles.com/practice-report-warrick-haggins-make-for-special-day-6/" /><link rel='shortlink' href='http://seminoles.com/?p=321910' /><link rel="alternate" type="application/json+oembed" href="http://seminoles.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fseminoles.com%2Fpractice-report-warrick-haggins-make-for-special-day-6%2F" /><link rel="alternate" type="text/xml+oembed" href="http://seminoles.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fseminoles.com%2Fpractice-report-warrick-haggins-make-for-special-day-6%2F&#038;format=xml" /> <script type="text/javascript">if(typeof videojs != "undefined") {
				videojs.options.flash.swf = "http://seminolesweb-8b76.kxcdn.com/wp-content/themes/seminoles/node_modules/videojs-swf/dist/video-js.swf";
			}
			document.createElement("video");document.createElement("audio");document.createElement("track");</script> <script type="text/javascript">var gptadslots=[];
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function(){ var gads = document.createElement('script');
	gads.async = true; gads.type = 'text/javascript';
	var useSSL = 'https:' == document.location.protocol;
	gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
	var node = document.getElementsByTagName('script')[0];
	node.parentNode.insertBefore(gads, node);
})();
googletag.cmd.push(function() {
              gptadslots[1]= googletag.defineSlot('/4177/cstv.fsu/frontpage', [[728,90]],'div-gpt-ad-995998085734115697-1').addService(googletag.pubads());
              googletag.pubads().enableSingleRequest();
              googletag.pubads().enableAsyncRendering();
              googletag.enableServices();
       });</script> </head><body class="post-template-default single single-post postid-321910 single-format-standard"> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

//Roll Up Account
ga('create', 'UA-11697686-1', {cookieDomain: 'seminoles.com', allowLinker: true, name: 'n1'});
ga('n1.require', 'linker');
ga('n1.linker:autoLink', ['seminoles.com', 'nmnathletics.com']);
ga('n1.send', 'pageview');

//WMT Tracking
ga('create', 'UA-103794602-1', {cookieDomain: 'seminoles.com', allowLinker: true, name: 'wmtTracker'});
ga('wmtTracker.require', 'linker');
ga('wmtTracker.linker:autoLink', ['seminoles.com', 'nmnathletics.com']);
ga('wmtTracker.send', 'pageview');

//seminoles tracking
ga('create', 'UA-17318783-2', {cookieDomain: 'seminoles.com', allowLinker: true, name: 'seminolesTracker'});
ga('seminolesTracker.require', 'linker');
ga('seminolesTracker.linker:autoLink', ['seminoles.com', 'nmnathletics.com']);
ga('seminolesTracker.send', 'pageview');</script><nav class="navbar navbar-default seminoles--nav-top"><div class="container seminoles--nav-top-container"><div class="seminoles--nav-top-block"><div class="navbar-header"> <button type="button" class="seminoles--nav-top-menu-button navbar-toggle collapsed "
 data-toggle="collapse"
 data-target="#seminoles-navbar-collapse" aria-expanded="false"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </button> <a class="navbar-brand" href="/"> <img src="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/08/c791c4d6-fsu-logo-8-e1502741638909.png" class="img-responsive"
 alt="Florida State Seminoles"/> </a></div></div><div id="seminoles-navbar-collapse" class="collapse navbar-collapse text-center"><div class="seminoles-relative-form"><ul class="nav navbar-nav navbar-right"><li class="seminoles-header-right-search"><div class="seminoles--header-right-search"><div href="#" class="seminoles--header-search-trigger"> <span class="fa fa-search fa-lg"></span></div></div><div class="seminoles--header-search-form-block"><form action="/search"> <input type="text" class="seminoles--header-search-form-input" name="search"
 title="Search on the website"
 placeholder="search"> <em class="fa fa-close seminoles--header-search-form-close"></em></form></div></li></ul></div><div class="seminoles-navbar-collapse-container"><ul id="menu-header-menu" class="nav navbar-nav seminoles--navbar"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-15" class="mega-dropdown menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-15 dropdown"><a title="Sports" href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true">Sports <span class="fa fa-caret-down"></span></a><ul role="menu" class="dropdown-menu mega-dropdown-menu" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-16" class="dropdown-root-item col-xs-12 col-md-4 col-md-offset-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-16"><a title="Men&#039;s Teams" href="#">Men&#8217;s Teams</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9392" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9392"><a title="Baseball" href="http://seminoles.com/sports/baseball/">Baseball</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-27" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27"><a title="Schedule" href="/sports/baseball/schedule/season/2017-18/">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-29" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29"><a title="Roster" href="/sports/baseball/roster">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36585" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36585"><a title="Stats" target="_blank" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/2018-Baseball-Stats.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-159" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-159"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSUBaseball" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-158" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-158"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUBaseball" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9097" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9097"><a title="Basketball" href="http://seminoles.com/sports/basketball/">Basketball</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18"><a title="Schedule" href="http://seminoles.com/sports/basketball/schedule/season/2017-18/">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-19" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19"><a title="Roster" href="http://seminoles.com/sports/basketball/roster/season/2017-18/">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36671" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36671"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/Stats1-7.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-32" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-32"><a title="fa-twitter" target="_blank" href="https://twitter.com/fsuhoops" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-33" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-33"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUMBasketball" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9394" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9394"><a title="Cross Country" href="http://seminoles.com/sports/crosscountry/">Cross Country</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9450"><a title="Schedule" href="/sports/crosscountry/schedule">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9497" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9497"><a title="Roster" href="/sports/crosscountry/roster">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36670" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36670"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/10/17-XC-Season-Stats-2.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9716" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9716"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSUXC" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9721" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9721"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUSeminolesCrossCountry" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9398" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-9398"><a title="Football" href="http://seminoles.com/sports/football/">Football</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9451" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9451"><a title="Schedule" href="/sports/football/schedule">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9499"><a title="Roster" href="/sports/football/roster">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36669" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36669"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/01/Updated-Season.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9736" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9736"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSU_Football" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9754" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9754"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUFootball" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9399" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9399"><a title="Golf" href="http://seminoles.com/sports/golf/">Golf</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9453"><a title="Schedule" href="http://seminoles.com/sports/golf/schedule/season/2017-18/">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9500" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9500"><a title="Roster" href="http://seminoles.com/sports/golf/roster/season/2017-18/">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36668" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36668"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/2017-18-MGO-Stats-1.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9739" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9739"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSUGolf" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9755" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9755"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUMensGolf" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9400" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9400"><a title="Swimming &amp; Diving" href="http://seminoles.com/sports/swimming-and-diving/">Swimming &#038; Diving</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9454" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9454"><a title="Schedule" href="http://seminoles.com/sports/swimming-and-diving/schedule/">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9508" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9508"><a title="Roster" href="/sports/swimming-and-diving/roster">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36687" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36687"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/07/30cd7388-sd-2017.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9738" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9738"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSU_Swimming" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9750" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9750"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUSwimmingDiving" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9401" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9401"><a title="Tennis" href="http://seminoles.com/sports/tennis/">Tennis</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9452"><a title="Schedule" href="http://seminoles.com/sports/tennis/schedule/season/2017-18/">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9506" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9506"><a title="Roster" href="http://seminoles.com/sports/tennis/roster/season/2017-18/">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36688" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36688"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/Season-Statistics-Men-8.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9735" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9735"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSU_MTennis" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9749" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9749"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUMTennis" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9402" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9402"><a title="Track &amp; Field" href="http://seminoles.com/sports/track-and-field/">Track &#038; Field</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9455" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9455"><a title="Schedule" href="/sports/track-and-field/schedule">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9513"><a title="Roster" href="/sports/track-and-field/roster">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-318818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-318818"><a title="Stats" href="https://www.tfrrs.org/teams/FL_college_f_Florida_State.html">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9733" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9733"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSU_track" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9756" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9756"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUTrack" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-22" class="dropdown-root-item col-xs-12 col-md-4 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-22"><a title="Women&#039;s Teams" href="#">Women&#8217;s Teams</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9407" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9407"><a title="Basketball" href="http://seminoles.com/sports/w-basketball/">Basketball</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-24" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24"><a title="Schedule" href="http://seminoles.com/sports/w-basketball/schedule/season/2017-18/">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-25" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25"><a title="Roster" href="http://seminoles.com/sports/w-basketball/roster/season/2017-18/">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36742" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36742"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/FSU-Stats-1718-4.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-157" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-157"><a title="fa-twitter" target="_blank" href="https://twitter.com/fsuwbb" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-160" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-160"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUWomensBasketball" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9404" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9404"><a title="Beach Volleyball" href="http://seminoles.com/sports/beach-volleyball/">Beach Volleyball</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9456"><a title="Schedule" href="/sports/beach-volleyball/schedule">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9504" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9504"><a title="Roster" href="/sports/beach-volleyball/roster">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36744" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36744"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/2018-BVB-Stats.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9734" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9734"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSU_BeachVB" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9745" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9745"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUBeachVB/?ref=hl" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-306357" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-306357"><a title="Cross Country" href="http://seminoles.com/sports/crosscountry/">Cross Country</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9459"><a title="Schedule" href="/sports/w-cross-country/schedule">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9501" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9501"><a title="Roster" href="/sports/w-cross-country/roster/">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36745" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36745"><a title="Stats" href="http://cs.seminoles.com/wp-content/uploads/2017/10/17-XC-Season-Stats-2.pdf?_ga=2.223739739.1398046235.1505664629-1431712411.1478794855">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9729" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9729"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSUXC" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9747" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9747"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUSeminolesCrossCountry" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9409" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9409"><a title="Golf" href="http://seminoles.com/sports/w-golf/">Golf</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9460"><a title="Schedule" href="http://seminoles.com/sports/w-golf/schedule/season/2017-18/">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9507"><a title="Roster" href="http://seminoles.com/sports/w-golf/roster/season/2017-18/">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36749" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36749"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/2017-18-Womens-Golf-Statistics-1-2.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9731" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9731"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSUGolf" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9742" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9742"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUWomensGolf" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9410" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9410"><a title="Soccer" href="http://seminoles.com/sports/soccer/">Soccer</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9461"><a title="Schedule" href="/sports/soccer/schedule">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9511" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9511"><a title="Roster" href="/sports/soccer/roster">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36750" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36750"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/11/2017-FSU-Season-Stats-2.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9730" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9730"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSUSoccer" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9751" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9751"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUSoccer" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9707" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9707"><a title="Softball" href="http://seminoles.com/sports/softball/">Softball</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9709" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9709"><a title="Schedule" href="/sports/softball/schedule">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9708" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9708"><a title="Roster" href="/sports/softball/roster">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36751" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36751"><a title="Stats" target="_blank" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/2018-FSU-Season-Stats-12.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9728" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9728"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSU_Softball" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9752" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9752"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUsoftball" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9412" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9412"><a title="Swimming &amp; Diving" href="http://seminoles.com/sports/w-swimming-diving/">Swimming &#038; Diving</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9464" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9464"><a title="Schedule" href="http://seminoles.com/sports/w-swimming-diving/schedule/season/2017-18/">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9509" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9509"><a title="Roster" href="/sports/w-swimming-diving/roster">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36753"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/07/30cd7388-sd-2017.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9732" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9732"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSU_Swimming" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9753" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9753"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUSwimmingDiving" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9413" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9413"><a title="Tennis" href="http://seminoles.com/sports/w-tennis/">Tennis</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9462"><a title="Schedule" href="http://seminoles.com/sports/w-tennis/schedule/season/2017-18/">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9498" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9498"><a title="Roster" href="http://seminoles.com/sports/w-tennis/roster/season/2017-18/">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36754" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36754"><a title="Stats" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/Season-Statistics-Women-6.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9726" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9726"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSU_WTennis" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9746" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9746"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSU.WTennis" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-306358" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-306358"><a title="Track &amp; Field" href="http://seminoles.com/sports/track-and-field/">Track &#038; Field</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9457" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9457"><a title="Schedule" href="/sports/w-track-and-field/schedule">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9503" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9503"><a title="Roster" href="http://seminoles.com/sports/w-track-and-field/roster/season/2017-18/">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36755" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36755"><a title="Stats" href="https://admin.xosn.com/fls/32900//pdf/2016%20Indoor%20Performance%20Stats.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9727" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9727"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSU_track" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9744" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9744"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUTrack" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9449" class="subitem menu-item menu-item-type-taxonomy menu-item-object-sport_category menu-item-has-children menu-item-9449"><a title="Volleyball" href="http://seminoles.com/sports/volleyball/">Volleyball</a><div class='inline-right-block'> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9458"><a title="Schedule" href="/sports/volleyball/schedule">Schedule</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9520"><a title="Roster" href="/sports/volleyball/roster">Roster</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-36756" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36756"><a title="Stats" target="_blank" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/12/Combined-12-1.pdf">Stats</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9724" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9724"><a title="fa-twitter" target="_blank" href="https://twitter.com/FSU_Volleyball" class="with-icon"><em class="fa fa-twitter" aria-hidden="true"></em>&nbsp;</a></span> <span itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9741" class="n-r-b menu-item menu-item-type-custom menu-item-object-custom menu-item-9741"><a title="fa-facebook" target="_blank" href="https://www.facebook.com/FSUVolleyball" class="with-icon"><em class="fa fa-facebook" aria-hidden="true"></em>&nbsp;</a></span></div></li></ul></li><div class="menu-ads menu-ads-21 col-md-3"><a href="https://frontier.com/" target="_blank"><img src="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/05/c37162ce-frontier-logo.png" alt="advertisement"></a></div></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-34" class="mega-dropdown menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-34 dropdown"><a title="Tickets" href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true">Tickets <span class="fa fa-caret-down"></span></a><ul role="menu" class="dropdown-menu mega-dropdown-menu" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10843" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 col-md-offset-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10843"><a title="dropdown1" href="#">dropdown1</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10820" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10820"><a title="Buy Tickets Now" target="_blank" href="https://ev6.evenue.net/cgi-bin/ncommerce3/SEGetGroupList?groupCode=FSU&#038;linkID=fsuse&#038;shopperContext=&#038;caller=&#038;appCode=&#038;DB_OEM_ID=32900">Buy Tickets Now</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-315308" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-315308"><a title="NoleTickets.com" href="http://seminoles.com/fsu-tickets/">NoleTickets.com</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-13293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13293"><a title="Ticket Office Information" href="http://seminoles.com/ticket-office-information/">Ticket Office Information</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-13297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13297"><a title="Student Tickets" href="http://seminoles.com/2017-18-student-ticket-information/">Student Tickets</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-13300" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13300"><a title="Travel Information" href="http://seminoles.com/travel/">Travel Information</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10839" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10839"><a title="dropdown 2" href="#">dropdown 2</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10834"><a title="Doak Campbell Stadium" target="_blank" href="http://www.seats3d.com/ncaa/florida_state_university/football/#/level_1/">Doak Campbell Stadium</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10822" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10822"><a title="Donald L. Tucker Center" target="_blank" href="http://ev6.evenue.net/evenue/linkID=fsuse/core/seating_charts.html#donald">Donald L. Tucker Center</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-13305" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13305"><a title="Dick Howser Stadium" href="http://seminoles.com/dick-howser-seating-chart/">Dick Howser Stadium</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-13307" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13307"><a title="Payroll Deduction Forms" href="http://seminoles.com/fsu-employee-payroll-deduction-schedule/">Payroll Deduction Forms</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-13311" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13311"><a title="Ticket Marketplace" href="http://seminoles.com/stubhub-the-official-fan-to-fan-ticket-marketplace/">Ticket Marketplace</a></li></ul></li><div class="menu-ads menu-ads-24 col-md-3"><a href="https://www.stubhub.com/florida-state-seminoles-tickets/grouping/199237/?gcid=chPRT-_-geoUS-_-genNCAA-_-cmplogo-_-partfsu" target="_blank"><img src="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/05/1cddc19b-stubhub-new-size.png" alt="advertisement"></a></div></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9086" class="mega-dropdown menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-9086 dropdown"><a title="Multimedia" href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true">Multimedia <span class="fa fa-caret-down"></span></a><ul role="menu" class="dropdown-menu mega-dropdown-menu" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12119" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 col-md-offset-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12119"><a title="dropdown1" href="#">dropdown1</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12118" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12118"><a title="Latest Videos" target="_blank" href="/videos/">Latest Videos</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-305435" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-305435"><a title="Nole Insiders" href="http://seminoles.com/sports/noles-insiders/">Nole Insiders</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12120"><a title="Listen Live For Free" target="_blank" href="http://seminoles.leanplayer.com">Listen Live For Free</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-304998" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-304998"><a title="Live Stats" href="http://www.statbroadcast.com/events/statbroadcast.php?t=1&#038;gid=fsu">Live Stats</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28354" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28354"><a title="Photo Galleries" href="http://seminoles.com/gallery/">Photo Galleries</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12123"><a title="ACC Network Extra" target="_blank" href="http://www.espn.com/watch/#channel/accextra/">ACC Network Extra</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12125" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12125"><a title="dropdown2" href="#">dropdown2</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12126" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12126"><a title="Seminoles iPhone App" target="_blank" href="https://itunes.apple.com/us/app/florida-state-seminoles-gameday/id900343913?mt=8">Seminoles iPhone App</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-303983" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-303983"><a title="Seminoles Android App" href="https://play.google.com/store/apps/details?id=com.fsu.gameday&#038;hl=en">Seminoles Android App</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28350"><a title="Broadcast Guide" href="http://seminoles.com/seminole-img-sports-network-broadcast-guide/">Broadcast Guide</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28357" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28357"><a title="Radio Affiliates" href="http://seminoles.com/seminole-img-sports-network-broadcast-guide/">Radio Affiliates</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28359" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28359"><a title="LEONARD HAMILTON CALL-IN SHOW" href="http://seminoles.com/the-leonard-hamilton-call-in-show-live-from-madison-social-in-college-town/">LEONARD HAMILTON CALL-IN SHOW</a></li></ul></li><div class="menu-ads menu-ads-27 col-md-3"><a href="https://www.nissanusa.com/" target="_blank"><img src="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/05/6a569c4a-nissan-logov4.png" alt="advertisement"></a></div></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9090" class="mega-dropdown menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-9090 dropdown"><a title="Department" href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true">Department <span class="fa fa-caret-down"></span></a><ul role="menu" class="dropdown-menu mega-dropdown-menu" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12131" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12131"><a title="dropdown1" href="#">dropdown1</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28366" class="menu-item menu-item-type-post_type menu-item-object-staff menu-item-28366"><a title="Vice President Stan Wilcox" href="http://seminoles.com/staff/stan-wilcox/">Vice President Stan Wilcox</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28368" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28368"><a title="Athletics Department" href="http://seminoles.com/athletics-department/">Athletics Department</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28369" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28369"><a title="Athletics Board" href="http://seminoles.com/athletics-board/">Athletics Board</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12139" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12139"><a title="Academics" href="http://saas.fsu.edu/">Academics</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12140" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12140"><a title="Athletic Training" target="_blank" href="https://fsusportsmedicine.com">Athletic Training</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12141" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12141"><a title="Community Service" href="/community-service/">Community Service</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28377" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28377"><a title="Compliance" href="http://seminoles.com/compliance/">Compliance</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-216778" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216778"><a title="Head Coaches" href="http://seminoles.com/head-coaches/">Head Coaches</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12133" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12133"><a title="dropdown2" href="#">dropdown2</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12134"><a title="Media Relations" href="/media-relations/">Media Relations</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12144" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12144"><a title="SAAC" href="/saac/">SAAC</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28380"><a title="Seminole Nutrition" href="http://seminoles.com/seminole-nutrition/">Seminole Nutrition</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12146" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12146"><a title="Sharepoint (FSU Athletics Intranet)" target="_blank" href="https://athletics.intranet.fsu.edu/?DB_OEM_ID=32900">Sharepoint (FSU Athletics Intranet)</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12147" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12147"><a title="Staff Directory" target="_blank" href="/staff-directory/">Staff Directory</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12149" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12149"><a title="Student Services" href="http://seminoles.com/sports/student-services/">Student Services</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12150" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12150"><a title="Marching Chiefs" target="_blank" href="http://www.marchingchiefs.fsu.edu">Marching Chiefs</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12136" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12136"><a title="dropdown3" href="#">dropdown3</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12153" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12153"><a title="Licensing" target="_blank" href="http://licensing.fsu.edu">Licensing</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12135" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12135"><a title="ACC" target="_blank" href="http://theacc.com">ACC</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12151" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12151"><a title="Alumni Association" target="_blank" href="http://alumni.fsu.edu/">Alumni Association</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-309156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-309156"><a title="Seminole Sports Marketing" href="http://seminoles.com/seminole-sports-marketing-internship/">Seminole Sports Marketing</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12154" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12154"><a title="Seminole Tribe Of Florida" target="_blank" href="http://www.semtribe.com">Seminole Tribe Of Florida</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12155" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12155"><a title="FSU.edu" target="_blank" href="http://fsu.edu">FSU.edu</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12156" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12156"><a title="Varsity Club" target="_blank" href="http://varsityclub.fsu.edu">Varsity Club</a></li></ul></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9089" class="mega-dropdown menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-9089 dropdown"><a title="Facilities" href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true">Facilities <span class="fa fa-caret-down"></span></a><ul role="menu" class="dropdown-menu mega-dropdown-menu" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12157" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 col-md-offset-1 col-lg-offset-2 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12157"><a title="dropdown1" href="#">dropdown1</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-306312" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-306312"><a title="Clear Bag Policy" href="http://seminoles.com/fsu-clear-bag-policy/">Clear Bag Policy</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12158" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12158"><a title="Doak Campbell Stadium" href="/sports/football/facilities/bobby-bowden-field-at-doak-s-campbell-stadium/">Doak Campbell Stadium</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12159" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12159"><a title="Football Facilities" href="http://seminoles.com/sports/football/facilities/360-football-facility-tours/">Football Facilities</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12160"><a title="Albert J. Dunlap Athletic Training Facility" href="/sports/football/facilities/albert-j-dunlap-athletic-training-facility/">Albert J. Dunlap Athletic Training Facility</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12161"><a title="Tucker Center" href="/sports/basketball/facilities/tucker-center-mbb-wbb/">Tucker Center</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12162" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12162"><a title="Dick Howser Stadium" href="/sports/baseball/facilities/dick-howser-stadium/">Dick Howser Stadium</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12163" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12163"><a title="Basketball Training Facility" href="/sports/basketball/facilities/basketball-training-facility/">Basketball Training Facility</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12164" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12164"><a title="Seminole Soccer Complex" href="/sports/soccer/facilities/the-seminole-soccer-complex/">Seminole Soccer Complex</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12165" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12165"><a title="Seminole Softball Complex" href="/sports/softball/facilities/joanne-graf-field/">Seminole Softball Complex</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12167" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12167"><a title="dropdown2" href="#">dropdown2</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12166" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12166"><a title="Seminole Golf Course" href="/sports/golf/facilities/seminole-golf-course/">Seminole Golf Course</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12168"><a title="Mike Long Track" href="/sports/track-and-field/facilities/florida-state-track-and-field-facilities/">Mike Long Track</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12169" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12169"><a title="Speicher Tennis Center" href="/sports/tennis/facilities/scott-speicher-tennis-center/">Speicher Tennis Center</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12170" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12170"><a title="Tully Gym" href="http://seminoles.com/sports/volleyball/facilities/tully-gymnasium/">Tully Gym</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12171" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12171"><a title="Morcom Aquatics Center" href="/sports/swimming-and-diving/facilities/morcom-aquatics-center/">Morcom Aquatics Center</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12172" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12172"><a title="Beach Volleyball Courts" href="/sports/beach-volleyball/facilities/beach-volleyball-courts/">Beach Volleyball Courts</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12173" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12173"><a title="Indoor Tennis Courts" href="/sports/tennis/facilities/indoor-tennis-courts">Indoor Tennis Courts</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12174"><a title="Moore Athletics Center" href="/sports/athletic-center/facilities/the-coyle-e-moore-athletics-center/">Moore Athletics Center</a></li></ul></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9088" class="mega-dropdown menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-9088 dropdown"><a title="Fans" href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true">Fans <span class="fa fa-caret-down"></span></a><ul role="menu" class="dropdown-menu mega-dropdown-menu" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12177" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 col-md-offset-1 col-lg-offset-2 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12177"><a title="dropdown1" href="#">dropdown1</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12178" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12178"><a title="Listen Live" href="http://seminoles.leanplayer.com">Listen Live</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-304945" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-304945"><a title="17-18 Master Events Calendar" href="http://seminoles.com/fsu-athletics-master-calendar/">17-18 Master Events Calendar</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-304586" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-304586"><a title="Download Calendars" href="http://seminoles.com/2017-18-downloadable-calendars/">Download Calendars</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28936" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28936"><a title="Traditions" href="http://seminoles.com/traditions/">Traditions</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-304760" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-304760"><a title="Friday Night Block Party" href="http://seminoles.com/block-party/">Friday Night Block Party</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28477" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28477"><a title="Hall Of Fame" href="http://seminoles.com/hall-of-fame/">Hall Of Fame</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28589" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28589"><a title="Noles In The Pros" href="http://seminoles.com/fans-noles-in-the-pros/">Noles In The Pros</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-26408" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26408"><a title="Visitors Center" href="http://seminoles.com/travel/">Visitors Center</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28938"><a title="Promotions" href="http://seminoles.com/promotions-giveaways/">Promotions</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28351" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28351"><a title="Desktop Wallpaper" href="http://seminoles.com/seminoles-com-desktop-wallpapers/">Desktop Wallpaper</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12187" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12187"><a title="dropdown2" href="#">dropdown2</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-315371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-315371"><a title="Social Media DIrectory" href="http://seminoles.com/social-media/">Social Media DIrectory</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28954" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28954"><a title="Birthday Baseball in the Park" href="http://seminoles.com/birthday-in-the-park/">Birthday Baseball in the Park</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28601" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28601"><a title="Summer Camps" href="http://seminoles.com/camps/">Summer Camps</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28599" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28599"><a title="Paint It Pink" href="http://seminoles.com/paint-it-pink/">Paint It Pink</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12190" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12190"><a title="Kids Club" target="_blank" href="https://www.fsukidsclub.com">Kids Club</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28960" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28960"><a title="Sports Posters" href="http://seminoles.com/sports-posters/">Sports Posters</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28970" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28970"><a title="Spirit Groups" href="http://seminoles.com/spirit-groups/">Spirit Groups</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28978"><a title="Garnet and Gold Guides" href="http://seminoles.com/garnet-and-gold-guides/">Garnet and Gold Guides</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-28980" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28980"><a title="Bat Girls" href="http://seminoles.com/bat-girls/">Bat Girls</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12196" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12196"><a title="Video Board Request Form" href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/08/faf013c5-video-board-form.pdf">Video Board Request Form</a></li></ul></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9087" class="mega-dropdown menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-9087 dropdown"><a title="Shop" href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true">Shop <span class="fa fa-caret-down"></span></a><ul role="menu" class="dropdown-menu mega-dropdown-menu" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12206" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 col-md-offset-1 col-lg-offset-2 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12206"><a title="dropdown1" href="#">dropdown1</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12197" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12197"><a title="Shop For Seminoles Gear" target="_blank" href="http://shop.seminoles.com/?utm_source=seminoles&#038;utm_medium=bm_referral&#038;utm_term=kw--|cpn--no_coupon|offer--no_offer&#038;utm_content=l--College|t--Florida_State_Seminoles|p--all_players|pc--all_product_categories|ag--NoGender&#038;utm_campaign=dest--fsuptr_ShopForSeminolesGear|creatv--|date--|geo--NoGeo&#038;_ga=2.78683670.309471926.1500220087-1431712411.1478794855">Shop For Seminoles Gear</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12198" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12198"><a title="Newest Arrivals" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles/so/newest_items?utm_source=seminoles&#038;utm_medium=bm_referral&#038;utm_term=kw--|cpn--no_coupon|offer--no_offer&#038;utm_content=l--College|t--Florida_State_Seminoles|p--all_players|pc--all_product_categories|ag--NoGender&#038;utm_campaign=dest--fsuptr_NewestArrivals|creatv--|date--|geo--NoGeo&#038;_ga=2.78683670.309471926.1500220087-1431712411.1478794855">Newest Arrivals</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12199"><a title="Men" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles_Mens?utm_source=seminoles&#038;utm_medium=bm_referral&#038;utm_term=kw--|cpn--no_coupon|offer--no_offer&#038;utm_content=l--College|t--Florida_State_Seminoles|p--all_players|pc--all_product_categories|ag--NoGender&#038;utm_campaign=dest--fsuptr_Men|creatv--|date--|geo--NoGeo&#038;_ga=2.77944598.309471926.1500220087-1431712411.1478794855">Men</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12200" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12200"><a title="Women" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles_Ladies?utm_source=seminoles&#038;utm_medium=bm_referral&#038;utm_term=kw--|cpn--no_coupon|offer--no_offer&#038;utm_content=l--College|t--Florida_State_Seminoles|p--all_players|pc--all_product_categories|ag--NoGender&#038;utm_campaign=dest--fsuptr_Ladies|creatv--|date--|geo--NoGeo&#038;_ga=2.77944598.309471926.1500220087-1431712411.1478794855">Women</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12201" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12201"><a title="Kids" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles_Kids?utm_source=seminoles&#038;utm_medium=bm_referral&#038;utm_term=kw--|cpn--no_coupon|offer--no_offer&#038;utm_content=l--College|t--Florida_State_Seminoles|p--all_players|pc--all_product_categories|ag--NoGender&#038;utm_campaign=dest--fsuptr_Kids|creatv--|date--|geo--NoGeo&#038;_ga=2.77944598.309471926.1500220087-1431712411.1478794855">Kids</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12202"><a title="Hats" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles_Hats?utm_source=seminoles&#038;utm_medium=bm_referral&#038;utm_term=kw--|cpn--no_coupon|offer--no_offer&#038;utm_content=l--College|t--Florida_State_Seminoles|p--all_players|pc--all_product_categories|ag--NoGender&#038;utm_campaign=dest--fsuptr_Hats|creatv--|date--|geo--NoGeo&#038;_ga=2.15121844.309471926.1500220087-1431712411.1478794855">Hats</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12203"><a title="Jerseys" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles_Jerseys?utm_source=seminoles&#038;utm_medium=bm_referral&#038;utm_term=kw--|cpn--no_coupon|offer--no_offer&#038;utm_content=l--College|t--Florida_State_Seminoles|p--all_players|pc--all_product_categories|ag--NoGender&#038;utm_campaign=dest--fsuptr_Jerseys|creatv--|date--|geo--NoGeo&#038;_ga=2.15121844.309471926.1500220087-1431712411.1478794855">Jerseys</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12208" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12208"><a title="Polo" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles_Polos?utm_source=seminoles&#038;utm_medium=bm_referral&#038;utm_term=kw--|cpn--no_coupon|offer--no_offer&#038;utm_content=l--College|t--Florida_State_Seminoles|p--all_players|pc--all_product_categories|ag--NoGender&#038;utm_campaign=dest--fsuptr_Polo|creatv--|date--|geo--NoGeo&#038;_ga=2.7191984.309471926.1500220087-1431712411.1478794855">Polo</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12207" class="dropdown-root-item dropdown-root-item-hidden col-xs-12 col-md-4 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12207"><a title="dropdown2" href="#">dropdown2</a><ul role="menu" class="row" ><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12205"><a title="Jackets" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles_Jackets?_ga=2.15121844.309471926.1500220087-1431712411.1478794855">Jackets</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12204" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12204"><a title="Sweatshirts" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles_Sweatshirts_And_Fleece?_ga=2.15121844.309471926.1500220087-1431712411.1478794855">Sweatshirts</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12209" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12209"><a title="T-Shirt" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles_T-Shirts?utm_source=seminoles&#038;utm_medium=bm_referral&#038;utm_term=kw--|cpn--no_coupon|offer--no_offer&#038;utm_content=l--College|t--Florida_State_Seminoles|p--all_players|pc--all_product_categories|ag--NoGender&#038;utm_campaign=dest--fsuptr_Tshirts|creatv--|date--|geo--NoGeo&#038;_ga=2.7191984.309471926.1500220087-1431712411.1478794855">T-Shirt</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12210" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12210"><a title="Home Decor" target="_blank" href="http://shop.seminoles.com/Deck_Out_Your_Dorm?utm_source=Seminoles.com&#038;utm_medium=Drop%20Down&#038;utm_campaign=Home%20Decor">Home Decor</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12211" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12211"><a title="Tailgate Gear" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles_Gameday_And_Tailgate?utm_source=seminoles&#038;utm_medium=bm_referral&#038;utm_term=kw--|cpn--no_coupon|offer--no_offer&#038;utm_content=l--College|t--Florida_State_Seminoles|p--all_players|pc--all_product_categories|ag--NoGender&#038;utm_campaign=dest--fsuptr_TailgateGear|creatv--|date--|geo--NoGeo&#038;_ga=2.132286030.1547060334.1498950571-908720562.1498950571">Tailgate Gear</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12212" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12212"><a title="Sale Items" target="_blank" href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles/on_sale/yes?utm_source=seminoles&#038;utm_medium=bm_referral&#038;utm_term=kw--|cpn--no_coupon|offer--no_offer&#038;utm_content=l--College|t--Florida_State_Seminoles|p--all_players|pc--all_product_categories|ag--NoGender&#038;utm_campaign=dest--fsuptr_SaleItems|creatv--|date--|geo--NoGeo&#038;_ga=2.163245052.1547060334.1498950571-908720562.1498950571">Sale Items</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-12213" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12213"><a title="Official Photo Store" target="_blank" href="http://www.replayphotos.com/floridastatephotostore/">Official Photo Store</a></li></ul></li></ul></li></ul></div></div></div></nav><nav class="navbar navbar-default seminoles--subnav"><div class="container"><div class="navbar-header seminoles--subnav-navbar-header"> <a class="navbar-brand" href="http://seminoles.com/sports/football/"> Football </a></div><div class="collapse navbar-collapse" id="seminoles-navbar-submenu-collapse"><ul class="nav navbar-nav seminoles--navbar seminoles--navbar-left"><li> <a href="/sports/football/roster/"> Roster </a></li><li> <a href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/2018-Spring-Guide.pdf"> Spring Guide </a></li><li> <a href="http://seminoles.com/springgame/"> Spring Game </a></li><li> <a href="/sports/football/schedule/"> Schedule </a></li><li> <a href="http://seminoles.com/staff-directory/department/football/"> Coaches </a></li><li> <a href="https://ev6.evenue.net/cgi-bin/ncommerce3/SEGetEventList?groupCode=FBSEASON&linkID=fsuse&shopperContext=&caller=&appCode="> Tickets </a></li><li> <a href="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/01/Updated-Season.pdf"> Stats </a></li><li> <a href="http://seminoles.com/football-links/"> Links </a></li><li> <a href="http://seminoles.com/football-archives"> Archives </a></li><li> <a href="http://shop.seminoles.com/COLLEGE_Florida_State_Seminoles_college_football_gear?_ga=2.154159992.1543525326.1499622602-1307901307.1495642590"> Shop </a></li></ul></div></div></nav><div id="seminoles--articles-wrapper"><div id="seminoles--single-article-321910"
 class="seminoles--single-article seminoles--article"
 data-url="http://seminoles.com/practice-report-warrick-haggins-make-for-special-day-6/"
 data-title="Practice Report: Warrick, Haggins Make For Special Day 6"
 data-article-id="321910"><div class="jumbotron seminoles--feature-image"
 style="background-image: url(http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/PWCA.jpg);
 background-position: center top"> <span rel="author" class="seminoles--image-author">Photo: Colin Abbey </span></div><div class="container seminoles--article-top-ad"><div><div class="row mb-20 mt-20"><div class="col-xs-12"><div class="seminoles--static-ads"><div id="seminoles--frontpage-top-539256" class="gpt">  <script type='text/javascript'>googletag.cmd.push(function () {
                var mapping = googletag.sizeMapping().addSize([0, 0], [[320, 50], [300, 50]]).// mobile
                addSize([748, 0], [[320, 50], [300, 50]]).//medium
                addSize([1050, 0], [[970, 90], [970, 66], [728, 90]]).build();//desktop
                googletag.pubads().setCentering(true);

                googletag.defineSlot('/4177/cstv.fsu/frontpage', [[970, 90], [970, 66], [728, 90]], 'seminoles--frontpage-top-539256')
                    .defineSizeMapping(mapping)
                    .addService(googletag.pubads());
                googletag.pubads().enableSyncRendering();
                googletag.enableServices();
                googletag.display('seminoles--frontpage-top-539256');
            });</script> </div></div></div></div></div></div><div class="seminoles--article-container"><div class="row seminoles--article-head"><div class="col-xs-12 col-md-2 seminoles--article-head-item hidden-xs hidden-sm"><ul class="list-unstyled seminoles--vertical-share"><li class="share"> <a href="#" data-share="share"  onclick="return emailShare(event);"> <em class="fa fa-envelope-o fa-stack"></em> </a></li><li class="seminoles--vertical-share-tw"> <a href="#" data-share="twitter" onclick="return twitterShare(event);"> <em class="fa fa-twitter fa-stack"></em> </a></li><li class="seminoles--vertical-share-fb"> <a href="#" data-share="facebook" onclick="return facebookShare(event);"> <em class="fa fa-facebook fa-stack"></em> </a></li><li class="seminoles--vertical-share-gp" onclick="return googlePlusShare(event);"> <a href="#" data-share="google"> <em class="fa fa-google-plus fa-stack"></em> </a></li></ul></div><div class="col-xs-12 col-md-8"><div class="row"><div class="col-xs-12 seminoles--article-head-item"><div class="text-muted"> March 30, 2018                                    - by <span class="seminoles--article-author">Tim Linafelt, Senior Writer</span></div> <span class="h1">Practice Report: Warrick, Haggins Make For Special Day 6</span></div><div class="col-xs-12 col-md-2 seminoles--article-head-item visible-xs-block visible-sm-block"><ul class="list-unstyled seminoles--vertical-share"><li class="share"> <a href="#" data-share="share"  onclick="return emailShare(event);"> <em class="fa fa-envelope-o fa-stack"></em> </a></li><li class="seminoles--vertical-share-tw"> <a href="#" data-share="twitter" onclick="return twitterShare(event);"> <em class="fa fa-twitter fa-stack"></em> </a></li><li class="seminoles--vertical-share-fb"> <a href="#" data-share="facebook" onclick="return facebookShare(event);"> <em class="fa fa-facebook fa-stack"></em> </a></li><li class="seminoles--vertical-share-gp" onclick="return googlePlusShare(event);"> <a href="#" data-share="google"> <em class="fa fa-google-plus fa-stack"></em> </a></li></ul></div></div></div></div><div class="row"><div class="seminoles--article-video col-xs-12 col-md-7 col-centered mb-20"><div class='wmt-video-embed-container responsive' style=''><iframe height='100%' width='100%' src='//video.wmt.media/embed/8f7eafc3-16a4-4f7a-8690-85b8cdff358d' scrolling='no' webkitallowfullscreen='true' mozallowfullscreen='true' allowfullscreen='true' frameborder='0'></iframe></div></div></div><div class="row"><div class="col-xs-12 col-md-7 col-md-offset-2"> <span class="h3 quote">'I'm always talking about, 'Do Something,' and Peter did something." — Willie Taggart</span></div></div><div class="row"><div class="col-xs-12 col-md-7 col-centered"><p>&nbsp;</p><p><strong>TALLAHASSEE, Fla. – Peter Warrick</strong> figured he was in Tallahassee to meet Florida State’s new coaching staff and tour his old stomping grounds.</p><p><strong>Odell Haggins</strong> figured it was a typical Friday during spring camp, a two-and-a-half-hour session in shells before the team’s first scrimmage the next day.</p><p>But after the Seminoles sped through 25 periods in the Albert J. Dunlap Practice Facility on a rainy morning, Warrick and Haggins, two of FSU’s all-time greats at their respective positions, were each honored and surprised with moments they’ll never forget.</p><p>It started when Rob Wilson, FSU’s associate athletics director for communications and longtime media relations director for Bobby Bowden in the 1990s, introduced Warrick to the current team in the post-practice huddle.</p><p>After Wilson reeled off Warrick’s laundry list of accomplishments – being a two-time consensus All-American, FSU’s all-time leader in receiving touchdowns, a 1999 national champion and 2000 first-round draft pick among them – he revealed to Warrick the real reason he was standing in front of the team:</p><p>Warrick’s No. 9 jersey will be retired this fall.</p><blockquote class="twitter-tweet" data-partner="tweetdeck"><p dir="ltr" lang="en">Congrats to <a href="https://twitter.com/Pdub80?ref_src=twsrc%5Etfw">@Pdub80</a>! 👏</p><p>He will have his #9 jersey retired this fall, just the 11th in FSU history.<a href="https://twitter.com/hashtag/SpringBall?src=hash&amp;ref_src=twsrc%5Etfw">#SpringBall</a> | <a href="https://twitter.com/hashtag/DoSomething?src=hash&amp;ref_src=twsrc%5Etfw">#DoSomething</a> <a href="https://t.co/iI2fk59VdV">pic.twitter.com/iI2fk59VdV</a></p><p>— FSU Football (@FSUFootball) <a href="https://twitter.com/FSUFootball/status/979750862590529536?ref_src=twsrc%5Etfw">March 30, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><p>“This is like the best news ever,” Warrick said with a wide grin. “I honestly didn’t have a clue. &#8230; It was a shock, but it’s a blessing. I’m overwhelmed. They almost made me shed a tear.”</p><p>Moments later, Doug Mannheimer, chairman of the FSU Hall of Fame and Recognition Committee, stepped in front of the team to deliver one more honor, this one to someone with whom the current Seminoles are a little more familiar.</p><p>Haggins, the former Seminole defensive lineman now approaching 25 years as an assistant, and who steadied the program as interim head coach last December, will be inducted into the FSU Athletics Hall of Fame later this year.</p><blockquote class="twitter-tweet" data-partner="tweetdeck"><p dir="ltr" lang="en">A heartfelt speech from <a href="https://twitter.com/odellhaggins?ref_src=twsrc%5Etfw">@odellhaggins</a>.</p><p>This is what he told the team after learning about his induction into the <a href="https://twitter.com/Seminoles?ref_src=twsrc%5Etfw">@Seminoles</a> Hall of Fame.<a href="https://twitter.com/hashtag/SpringBall?src=hash&amp;ref_src=twsrc%5Etfw">#SpringBall</a> | <a href="https://twitter.com/hashtag/DoSomething?src=hash&amp;ref_src=twsrc%5Etfw">#DoSomething</a> <a href="https://t.co/SmKx7zp78C">pic.twitter.com/SmKx7zp78C</a></p><p>— FSU Football (@FSUFootball) <a href="https://twitter.com/FSUFootball/status/979764000106967041?ref_src=twsrc%5Etfw">March 30, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><p>“I’m lost for words, but it means a lot,” Haggins said. “I was given this opportunity by Bobby Bowden to be here as a player. And it made me a better man, in my life, the way he treated me. … This place has done a lot for me, and I thank Florida State and the people at Florida State University for giving me this opportunity back in 1985. It means the world. … I just want to thank God for that.”</p><p>Warrick is joining company both exclusive and elite. He’s the 11<sup>th</sup> FSU football player to have his jersey retired, and first since linebacker Marvin Jones (55) in 2015. The others include Deion Sanders (2), Derrick Brooks (10), Chris Weinke (16), Charlie Ward (17), Fred Biletnikoff (25), Terrell Buckley (27), Warrick Dunn (28), Ron Sellers (34) and Ron Simmons (50).</p><p>Haggins, meanwhile, will be the 99<sup>th</sup> FSU football player to join the Hall of Fame. Per committee policy, current university employees are not eligible to be inducted. But given both the length and significance of Haggins’ contributions to Florida State, the committee made an exception.</p><p>“It couldn’t go to two better guys than Odell and Peter Warrick,” coach <strong>Willie Taggart</strong> said. “Both guys love this place, both guys take care of their business and both those guys help make us proud.”</p><p>One of Taggart’s priorities over the last few weeks has been to get more former players involved with the program and, in turn, to have his players learn as much as they can from their predecessors.</p><p>Warrick certainly seemed up for it. After practice, he spoke to a huddled group of receivers for several minutes, then stuck around to toss passes, pose for pictures and exchange phone numbers.</p><blockquote class="twitter-tweet" data-partner="tweetdeck"><p dir="ltr" lang="en">S/o To big bro <a href="https://twitter.com/Pdub80?ref_src=twsrc%5Etfw">@Pdub80</a> on getting his Number Retired Big Blessings Hard work pay off  He came and Handed Me the torch Today ✈🙏🏾 <a href="https://twitter.com/hashtag/SkrtSkrt?src=hash&amp;ref_src=twsrc%5Etfw">#SkrtSkrt</a> <a href="https://t.co/AFbpzBEXS1">pic.twitter.com/AFbpzBEXS1</a></p><p>— 🖤 (@dat_dj) <a href="https://twitter.com/dat_dj/status/979748774372311041?ref_src=twsrc%5Etfw">March 30, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>“I’m always talking about, ‘Do Something,’ and Peter did something,” said Taggart, who grew up near Warrick in Palmetto, Fla., and competed against him in both youth and high-school football.</p><p>“That just goes to show how much everyone appreciates what he did here. He’s always been that way. It was expected. Peter has always been the man. He’s been a &#8216;dude&#8217; his entire life.”</p><p>And Haggins, of course, has been investing in future Seminole generations ever since joining Bowden’s staff in 1994.</p><p>As far as Taggart is concerned, there is no better bridge between the players of yesterday and today.</p><p>“Odell doesn’t just talk about it. He is about it,” Taggart said. “He lives the Florida State way. You can tell that that garnet and gold is in his DNA, and the guys appreciate that.”</p><p>Here are other highlights from Friday’s practice.</p><p><strong>Terry, Gavin embrace expanded roles: </strong>While the Seminoles might not have the deepest numbers on their receiver depth chart, they more than make up for it in apparent big-play ability. Although much of the focus this spring has been on sophomore <strong>D.J. Matthews</strong> and the injured <strong>Nyqwan Murray</strong>, both redshirt freshman <strong>Tamorrion Terry </strong>and junior <strong>Keith Gavin </strong>have spent the last week providing FSU’s quarterbacks with big-bodied targets on the outside.</p><p>The two are working almost exclusively with the first-team offense, they have made at least one big play in seemingly every practice, and, most importantly to <strong>James Blackman</strong>, <strong>Bailey Hockman</strong> and <strong>Deondre Francois</strong>, they are both able to get up high and make plays on the ball.</p><p>Terry stands at 6-foot-4, 197 pounds, while Gavin isn’t far behind at 6-3, 217.</p><p>“(Lining up outside) was new to me,” Gavin said. “I like it a lot, though. I still have 1-on-1 (matchups) with most DBs and I have a lot of room to work.”</p><p>Gavin is looking to take a step forward from last year, in which he appeared in 10 games and finished with 27 catches for 278 yards.</p><p>And Terry is in line to make his first impact at the college level after redshirting a year ago.</p><p>“Those guys are strong, they’re physical,” Taggart said. “Whenever you’ve got strong, physical receivers that can catch the ball, they can do a lot of damage for you.”</p><p><strong>Situational scrimmage up next: </strong>Taggart will cross off another checkpoint on Saturday morning when he holds his first team scrimmage as Florida State’s head coach. Rather than have a true game simulation, Taggart intends to work offense versus defense in a number of in-game scenarios – think red-zone, short-yardage, two-minute drill and the like.</p><p>A full scrimmage will follow at the end of next week’s practices, and, of course, the Garnet &amp; Gold Game will be held on April 14.</p><p>“So often, you just put them out there, 11-on-11, and tell them to play football. And they’re running plays but they’re not understanding the situation,” Taggart said. “We’re just trying to teach our guys the game. We’re going to put our guys in a lot of game situations and make sure they’re locked in and understanding where they’re at and not just running lines in a playbook.”</p><p><strong>Specialists pushing themselves: </strong>For the first time in their careers, specialists <strong>Ricky Aguayo </strong>and <strong>Logan Tyler</strong> have a dedicated position coach in <strong>Alonzo Hampton</strong>. And they’re also among the only Seminoles without any competition for their starting jobs. At least not in the most obvious sense.</p><p>But while the two veterans will likely reprise their roles as FSU’s kicker and punter this fall, that doesn’t mean Taggart has them resting on their laurels this spring.</p><p>Tyler has looked solid throughout the spring, booming a number of kicks to a waiting group of returners that includes <strong>Levonta Taylor</strong>, <strong>Khalan Laborn, D.J. Matthews, </strong>Gavin and <strong>Zaquandre White</strong>.</p><p>And Taggart has kept Aguayo engaged by implementing the kicking version of a pop quiz – surprise field-goal drills during practice in which Aguayo must step up and attempt without any advanced notice. If Aguayo makes it, the team might be in for a lighter day of post-practice conditioning. If he misses, well &#8230; let’s just say it makes for about as much pressure as there can be in mid-March.</p><p>“There will be times in practice where we’ll just call a field goal,” Taggart said. “And you’ve got to be ready. You don’t know when that time’s going to be … You’ve just got to be ready to come win the ballgame for us.”</p><p><strong>Atkins brothers visit: </strong>It’s getting a little tricky to keep up with all the former players visiting, but, in addition to Warrick, former FSU lineman <strong>Dumaka Atkins </strong>and his brother, former Miami standout <strong>Baraka Atkins</strong>, were in attendance.</p><p>The two competed against each other during the mid-2000s.</p><p><strong>Extra highlights: Bailey Hockman </strong>had an impressive sequence in which he evaded a heavy pass rush, rolled to his left and floated a pass over a defender and into the arms of <strong>Deonte Sheffield</strong>, who took care of the rest for a long touchdown. … Sheffield later a caught another TD on a smooth crossing route across the back of the end zone during 7 on 7 drills. … White broke free for a 45-yard touchdown run up the middle. … <strong>Levonta Taylor </strong>showed off his instincts and athleticism by sitting on a short out route, jumping in front of the pass and taking off for what would have been an easy pick-six during short-yardage drills. (Incidentally, the quarterback who threw the pass then took off for a lap around the practice field, another new Taggart tradition.)</p><p><a class="twitter-follow-button" href="https://twitter.com/Tim_Linafelt" data-show-count="false">Follow @Tim_Linafelt</a><script async="" src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p></div></div><div><div class="row mb-20 mt-20"><div class="col-xs-12"><div class="seminoles--static-ads"><div id="seminoles--frontpage-top-659000" class="gpt">  <script type='text/javascript'>googletag.cmd.push(function () {
                var mapping = googletag.sizeMapping().addSize([0, 0], [[320, 50], [300, 50]]).// mobile
                addSize([748, 0], [[320, 50], [300, 50]]).//medium
                addSize([1050, 0], [[970, 90], [970, 66], [728, 90]]).build();//desktop
                googletag.pubads().setCentering(true);

                googletag.defineSlot('/4177/cstv.fsu/frontpage', [[970, 90], [970, 66], [728, 90]], 'seminoles--frontpage-top-659000')
                    .defineSizeMapping(mapping)
                    .addService(googletag.pubads());
                googletag.pubads().enableSyncRendering();
                googletag.enableServices();
                googletag.display('seminoles--frontpage-top-659000');
            });</script> </div></div></div></div></div></div></div><div class="container"><div class="row"><div class="col-xs-12 text-center"> <span class="h3 seminoles--article-related-title">Related Articles</span></div></div></div><div class="seminoles--related-articles"> <a href="http://seminoles.com/photo-gallery-spring-ball-day-5/"
 class="col-xs-12 col-md-6 seminoles--related-article"
 style="background-image: url(http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/Website-20180328-RCA_8838-1024x576.jpg);"><div class="overlay"></div><div class="content"><h5>March 28, 2018</h5><h6>Photo Gallery: Spring Ball 2018 Day 5</h6></div> </a> <a href="http://seminoles.com/sights-and-sounds-march-28-2/"
 class="col-xs-12 col-md-6 seminoles--related-article"
 style="background-image: url(http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2018/03/Website-20180328-RCA_8654-1024x576.jpg);"><div class="overlay"></div><div class="content"><h5>March 28, 2018</h5><h6>Sights and Sounds: March 28</h6></div> </a></div></div></div></div></div> <script type="text/javascript">jQuery(document).ready(function () {
            var $infiniteArticle = new InfiniteScroll({
                selector: '#seminoles--articles-wrapper',
                childSelector: '.seminoles--article',
                limit: 4,
                url: '/wp-json/seminoles/v1/infinite_scroll_article',
                data: {
                    dateStart: '1522429774',
                    postID: 321910,
                },
                sportCategories: [10,156],
                scrollSpy: true,
                scrollSpyElementClass: 'seminoles--single-infinite-article'
            });
            $infiniteArticle.infiniteSeminolesBlocks();
            $infiniteArticle.scrollSpyUpdateUrl('#seminoles--single-article-321910');

        });</script> <div class="container"><div><div class="row mb-20 mt-20"><div class="col-xs-12"><div class="seminoles--static-ads"><div id="seminoles--frontpage-top-53806" class="gpt">  <script type='text/javascript'>googletag.cmd.push(function () {
                var mapping = googletag.sizeMapping().addSize([0, 0], [[320, 50], [300, 50]]).// mobile
                addSize([748, 0], [[320, 50], [300, 50]]).//medium
                addSize([1050, 0], [[970, 90], [970, 66], [728, 90]]).build();//desktop
                googletag.pubads().setCentering(true);

                googletag.defineSlot('/4177/cstv.fsu/frontpage', [[970, 90], [970, 66], [728, 90]], 'seminoles--frontpage-top-53806')
                    .defineSizeMapping(mapping)
                    .addService(googletag.pubads());
                googletag.pubads().enableSyncRendering();
                googletag.enableServices();
                googletag.display('seminoles--frontpage-top-53806');
            });</script> </div></div></div></div></div><div class="seminoles--footer"><div class="row"><div class="col-xs-12"><div class="seminoles--footer-row"><div class="seminoles--footer-image"> <a href="http://www.imgcollege.com/" target="_blank"> <img src="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/05/d2c959b6-imgc-logo-blue.jpg" alt="advertisement"/></a></div><div class="seminoles--footer-image"> <a href="http://www.theacc.com/" target="_blank"> <img src="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/05/5ad669d0-4d45aa91-acc-logo.png" alt="advertisement"/></a></div><div class="seminoles--footer-image"> <a href="http://www.fsu.edu/" target="_blank"> <img src="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/05/482c7cf4-56464465-fsu-seal.png" alt="advertisement"/></a></div><div class="seminoles--footer-image"> <a href="http://webmetech.com/" target="_blank"> <img src="http://seminolesweb-8b76.kxcdn.com/wp-content/uploads/2017/05/ace0189c-cf88660a-webme.png" alt="advertisement"/></a></div></div></div><div class="col-xs-12 text-center text-uppercase seminoles--copyright"> Copyright &copy; 2018, Florida State University. All Rights Reserved.</div></div></div></div> <script type="text/javascript">var adTagFormat = 'http://pubads.g.doubleclick.net/gampad/ads?sz=640x480&iu=/8264/vaw-sports/desktop/college/fsu&ciu_szs=300x250&impl=s&gdfp_req=1&env=vp&output=xml_vmap1&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp';

        window.imaTag = function () {
            var referrer = "";

            try {
                referrer = window.parent.location.href;
            } catch (err) {
                // ignore security errors
            }

            var isMobile = false; //initiate as false
            // device detection
            if (/(android|bb\d+|meego).+mobile|avantgo|bada\/|blackberry|blazer|compal|elaine|fennec|hiptop|iemobile|ip(hone|od)|ipad|iris|kindle|Android|Silk|lge |maemo|midp|mmp|netfront|opera m(ob|in)i|palm( os)?|phone|p(ixi|re)\/|plucker|pocket|psp|series(4|6)0|symbian|treo|up\.(browser|link)|vodafone|wap|windows (ce|phone)|xda|xiino/i.test(navigator.userAgent)
                || /1207|6310|6590|3gso|4thp|50[1-6]i|770s|802s|a wa|abac|ac(er|oo|s\-)|ai(ko|rn)|al(av|ca|co)|amoi|an(ex|ny|yw)|aptu|ar(ch|go)|as(te|us)|attw|au(di|\-m|r |s )|avan|be(ck|ll|nq)|bi(lb|rd)|bl(ac|az)|br(e|v)w|bumb|bw\-(n|u)|c55\/|capi|ccwa|cdm\-|cell|chtm|cldc|cmd\-|co(mp|nd)|craw|da(it|ll|ng)|dbte|dc\-s|devi|dica|dmob|do(c|p)o|ds(12|\-d)|el(49|ai)|em(l2|ul)|er(ic|k0)|esl8|ez([4-7]0|os|wa|ze)|fetc|fly(\-|_)|g1 u|g560|gene|gf\-5|g\-mo|go(\.w|od)|gr(ad|un)|haie|hcit|hd\-(m|p|t)|hei\-|hi(pt|ta)|hp( i|ip)|hs\-c|ht(c(\-| |_|a|g|p|s|t)|tp)|hu(aw|tc)|i\-(20|go|ma)|i230|iac( |\-|\/)|ibro|idea|ig01|ikom|im1k|inno|ipaq|iris|ja(t|v)a|jbro|jemu|jigs|kddi|keji|kgt( |\/)|klon|kpt |kwc\-|kyo(c|k)|le(no|xi)|lg( g|\/(k|l|u)|50|54|\-[a-w])|libw|lynx|m1\-w|m3ga|m50\/|ma(te|ui|xo)|mc(01|21|ca)|m\-cr|me(rc|ri)|mi(o8|oa|ts)|mmef|mo(01|02|bi|de|do|t(\-| |o|v)|zz)|mt(50|p1|v )|mwbp|mywa|n10[0-2]|n20[2-3]|n30(0|2)|n50(0|2|5)|n7(0(0|1)|10)|ne((c|m)\-|on|tf|wf|wg|wt)|nok(6|i)|nzph|o2im|op(ti|wv)|oran|owg1|p800|pan(a|d|t)|pdxg|pg(13|\-([1-8]|c))|phil|pire|pl(ay|uc)|pn\-2|po(ck|rt|se)|prox|psio|pt\-g|qa\-a|qc(07|12|21|32|60|\-[2-7]|i\-)|qtek|r380|r600|raks|rim9|ro(ve|zo)|s55\/|sa(ge|ma|mm|ms|ny|va)|sc(01|h\-|oo|p\-)|sdk\/|se(c(\-|0|1)|47|mc|nd|ri)|sgh\-|shar|sie(\-|m)|sk\-0|sl(45|id)|sm(al|ar|b3|it|t5)|so(ft|ny)|sp(01|h\-|v\-|v )|sy(01|mb)|t2(18|50)|t6(00|10|18)|ta(gt|lk)|tcl\-|tdg\-|tel(i|m)|tim\-|t\-mo|to(pl|sh)|ts(70|m\-|m3|m5)|tx\-9|up(\.b|g1|si)|utst|v400|v750|veri|vi(rg|te)|vk(40|5[0-3]|\-v)|vm40|voda|vulc|vx(52|53|60|61|70|80|81|83|85|98)|w3c(\-| )|webc|whit|wi(g |nc|nw)|wmlb|wonu|x700|yas\-|your|zeto|zte\-/i.test(navigator.userAgent.substr(0, 4))) isMobile = true;

            var macros = {
                'timestamp': new Date().getTime(),
                'platform_category': !isMobile ? 'desktop' : 'mobile_web',
                'referrer_url': referrer,
                'description_url': referrer,
                'title': 'Practice Report: Warrick, Haggins Make For Special Day 6'
            };

            return Object.keys(macros).reduce(function (str, macro) {
                str = str.replace(new RegExp("\\[" + macro + "\\]", "g"), macros[macro]);
                return str;
            }, adTagFormat);
        };


        window.imaTagUrl = window.imaTag();</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"http:\/\/seminoles.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};</script> <script type='text/javascript' src='http://seminoles.com/wp-content/themes/seminoles/build/js/main.js?ver=1521826739'></script> <script type='text/javascript' src='//imasdk.googleapis.com/js/sdkloader/ima3.js'></script> <div class="seminoles--popup-wrapper" id="seminoles--popup"><div class="seminoles--close-popup"> <em class="fa fa-close fa-2x fa-stack text-center"></em></div><div class="seminoles--popup-container"><div class="text-center"><div class="spinner"><div class="sk-fading-circle"><div class="sk-circle1 sk-circle"></div><div class="sk-circle2 sk-circle"></div><div class="sk-circle3 sk-circle"></div><div class="sk-circle4 sk-circle"></div><div class="sk-circle5 sk-circle"></div><div class="sk-circle6 sk-circle"></div><div class="sk-circle7 sk-circle"></div><div class="sk-circle8 sk-circle"></div><div class="sk-circle9 sk-circle"></div><div class="sk-circle10 sk-circle"></div><div class="sk-circle11 sk-circle"></div><div class="sk-circle12 sk-circle"></div></div></div></div><div class="content"></div></div></div><script type="text/javascript" defer src="http://seminolesweb-8b76.kxcdn.com/wp-content/cache/autoptimize/js/autoptimize_a8dbdb8bf1907c56c33ad1d4ddd7297c.js"></script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"92f396f5c0","applicationID":"57137637","transactionName":"bgZRbEVXC0pWBUJeXVdMcltDXwpXGBVfWVVVBg==","queueTime":0,"applicationTime":1301,"atts":"QkFSGg1NGEQ=","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 7225/527 objects using redis
Application Monitoring using New Relic

Served from: seminoles.com @ 2018-03-31 08:42:35 by W3 Total Cache
-->